ArcObjects SDK 10.2.x system requirements

Visit Esri Support for information on earlier versions.

Supported Windows platforms*

Operating System(s)

Minimum Version

Maximum Version

ArcObjects SDK for the Java Platform

ArcObjects SDK for Cross Platform C++

ArcObjects SDK for the Microsoft .NET Framework

Windows 8.1 Basic, Pro and Enterprise (32 bit and 64 bit [EM64T])*

Update: April 2014

Not Supported

Supported

Supported

Windows 8 Basic, Pro and Enterprise (32-bit and 64-bit [EM64T])

Supported

Supported

Supported

Windows 7 Ultimate, Enterprise, Professional, Home Premium (32 bit and 64 bit [EM64T])

SP1

Supported

Supported

Supported

Windows Vista Ultimate, Enterprise, Business, Home Premium (32 bit and 64 bit [EM64T])

SP2

SP2

Supported

Supported

Supported

Windows XP Professional Edition, Home Edition (32 bit)

SP3

SP3

Supported

Supported

Supported

Windows XP Professional Edition, Home Edition (64 bit [EM64T])

SP2

SP2

Supported

Supported

Supported

Windows Server 2012 R2 Standard, and Datacenter (64 bit [EM64T])*

Update: April 2014

Not Supported

Supported

Supported

Windows Server 2012 Standard, and Datacenter (64 bit [EM64T])

Supported

Supported

Supported

Windows Server 2008 R2 Standard, Enterprise, and Datacenter (64 bit [EM64T])

SP1

Supported

Supported

Supported

Windows Server 2008 Standard, Enterprise, and Datacenter (32 bit and 64 bit [EM64T])

SP2

SP2

Supported

Supported

Supported

Windows Server 2003 Standard, Enterprise, and Datacenter (32 bit and 64 bit [EM64T])

SP2

SP2

Supported

Supported

Supported

NoteNote:

Microsoft Windows Server 2003, 2003 R2, Vista and XP are no longer supported starting at ArcGIS 10.2.2.

For more information, see Operating system requirements and limitations for additional requirements and information.

* Support for Windows 8.1 and Windows Server 2012 R2 begins at ArcGIS 10.2.1.

Supported Linux platforms*

Operating System(s)

Minimum Version

Maximum Version

ArcObjects SDK for the Java Platform

ArcObjects SDK for Cross Platform C++

ArcObjects SDK for the Microsoft .NET Framework

Red Hat Enterprise Linux Server 5 (32 bit and 64 bit)

Update 7 with libX11-1.0.3-11 patch

Latest maintenance update

Supported

Supported

Not Supported

Red Hat Enterprise Linux Server 6 (32 bit and 64 bit)

Update1

Latest maintenance update

Supported

Supported

Not Supported

SUSE Linux Enterprise Server 11 (32 bit and 64 bit)

SP1

Supported

Supported

Not Supported

*For more information, see Operating system requirements and limitations for additional requirements and information.

Hardware requirements

Disk space requirements

Microsoft Windows

Linux

ArcObjects SDK for the Java Platform

630 MB

648 MB

ArcObjects SDK for Cross Platform C++

670 MB

588 MB

ArcObjects SDK for the Microsoft .NET Framework

938 MB

Not Applicable

Developer Solutions (SDK) requirements

ArcObjects SDK

Supported and Recommended IDE(s)

SDK Requirements

ArcObjects SDK for the Java Platform

Developer IDE plug-ins, which offer an enhanced developer experience through templates, code snippets, and project wizards, are provided with the ArcObjects SDK for the Java Platform and are supported in the IDEs listed below: (Note: Visual beans users must manually install Visual Editor.)

  • Eclipse Indigo (3.7) SR1 IDE for Java Developers
  • Eclipse Juno (4.2) SR1 and SR2 IDE for Java Developers
  • Eclipse Juno (4.2) SR1 and SR2 IDE for Java EE Developers

ArcGIS for Desktop, ArcGIS Engine, or ArcGIS for Server is required to develop with ArcObjects SDK.

Java Development Kit (JDK) version 6. Update 20 and above are supported.

ArcObjects SDK for Cross Platform C++

Supported Widget Toolkit(s)

NoteNote:

Only the Qt Commercial License is supported with 3.3.8 and 4.2.3.

Windows

Linux

Motif

Not Applicable

2.2.3

GTK

2.4.14

2.4.13

QT3

3.3.8

3.3.8

QT4

4.7.3

4.7.3

WX

2.8.7

2.8.7-GTK

NoteNote:

Microsoft Visual Studio is also required on Windows. Supported Visual Studio versions include

  • Microsoft Visual Studio 2010 (C++) Professional, Premium, Ultimate Edition (with or without Service Pack 1).
  • Microsoft Visual Studio 2012 (C#, VB.NET) Professional, Premium, Ultimate Edition.

ArcGIS Engine is required to develop with ArcObjects SDK.

Windows: Microsoft .NET Framework 3.5 Service Pack 1

ArcObjects SDK for the Microsoft .NET Framework

Microsoft Visual Studio 2010 (C#, VB.NET) Professional, Premium, Ultimate Edition

Microsoft Visual Studio 2010 Visual Basic Express

Microsoft Visual Studio 2010 Visual C# Express

NoteNote:

Supported editions of Visual Studio 2010 may be used with or without Service Pack 1.

Microsoft Visual Studio 2012 (C#, VB.NET) Professional, Premium, Ultimate Edition

ArcGIS for Desktop, ArcGIS Engine, or ArcGIS for Server is required to develop with ArcObjects SDK.

Microsoft .NET Framework 3.5 Service Pack 1

Operating system requirements and limitations

All platforms

Windows

Linux

6/24/2016