Operating System Limitations—Linux

ArcGIS Engine-related products are only supported on Linux x86 (that is, on CPUs that adhere to the x86 architecture) with supported Linux releases.

It is a requirement that the OS (binary) not been modified. Esri does not support any support a developer's release of any operating system.

Red Hat Enterprise Linux Server 5

The Red Hat Enterprise Linux Server 5 Update 7 (32-bit and 64-bit) with the libX11-1.0.3-11 patch minimum will be supported as long as it is from Red Hat without any modification to the latest kernel/glibc version.

The following packages are required:

The Base System > X Window System—all package groups

The Base System > Legacy Software Support group, including the following from Optional Packages:

  • compat-libstdc++-33
  • compat-libstdc++-296
  • compat-libf2c
  • compat-libgcc-296
  • compat-openldap-2.3

The Development > Development Tools—all package groups

The Development > Legacy Software Development—all package groups

The Development > X Software Development group - all package groups

The Optionals Repository > freeglut -2.4

  • libXp and libXp-devel packages
  • libXtst and libXtst-devel packages

The following additional software packages are required:

  • cairo
  • compat-libf2c-34 (Fortran 77 compatibility)
  • compat-gcc-34
  • GNU arbitrary precision library - gmp-4 package
  • GNU C Library (glibc) 2.5
  • gkt2-2.10 and gtk2-devel-2.10
  • libgfortran44*
  • libidn
  • libstdc++-4.1
  • libXss.so.1
  • OpenGL package: including mesa-libGL-6.5* and mesa-libGLU-6.5*
  • Openldap package: openldap
  • Openssl package: openssl
  • Readline Library: readline

NoteNote:

  • All package versions listed must be at level stated or higher.
  • On x86_64 platforms, if i386 (32-bit) versions of the above packages are available, they must be installed prior to installing ArcGIS.

Red Hat Enterprise Linux Server 6

The Red Hat Enterprise Linux Server 6 Update 1 (32-bit and 64-bit) minimum will be supported as long as it is from Red Hat without any modification to the latest kernel/glibc version.

The following packages are required:

The Base System > X Window System—all package groups

The Base System > Legacy Software Support group, including the following from Optional Packages:

  • compat-libstdc++-3.3
  • compat-libstdc++-296
  • compat-libf2c

The Development > Development Tools—all package groups

The Development > Legacy Software Development—all package groups

The Development > X Software Development group - all package groups

  • libXp and libXp-devel packages
  • libXtst and libXtst-devel packages

The Optionals Repository > freeglut -2.4

The LSB base libraries support for Red Hat Enterprise Linux: redhat-lsb-4.0-3

The following additional software packages are required:

  • cairo
  • compat-libf2c-34 (Fortran 77 compatibility)
  • compat-gcc-34
  • GNU arbitrary precision library - gmp-4 package
  • GNU libc Libraries (glibc) 2.12
  • gtk2-2.10 and gtk2-devel-2.10
  • libgfortran44*
  • libidn
  • libXScrnSaver-1.2.0-1.el6
  • libstdc++-4.4
  • libXss.so.1
  • OpenGL package: including mesa-libGL-6.5* and mesa-libGLU-6.5*
  • Openldap package: openldap
  • Openssl package: openssl
  • Readline Library: readline

NoteNote:

  • All package versions listed must be at level stated or higher.
  • On x86_64 platforms, if i686 (32-bit) versions of the above packages are available, they must be installed prior to installing ArcGIS.

SuSE Linux Enterprise Server 11

The Linux patches for SUSE Linux Enterprise Server (32-bit and 64-bit) will be supported as long as they are from SUSE Linux without modification to the latest kernel/glibc version.

The following packages are required:

From Development > Languages > Fortran group

  • libg2c33
  • libgfortran43*

From Development > Libraries > X11 group

  • cairo
  • gtk and gtk-devel version 2.18 minimum
  • Openmotif package— openmotif and openmotif-devel

From the System/Libraries group

  • compat-dapl
  • freeglut and freeglut-devel
  • GNU C Library (glibc) package version 2.3.4-2 minimum
  • GNU MP Library - gmp package
  • libidn package
  • Mesa: includes libGL and libGLU
  • Readline Library: libreadline5
  • xorg-x11-libX11 and development packages
  • xorg-X11-libXp and development packages
  • xorg-X11-libXt and development packages

From the System/X11/Servers/XF86_4 group

  • xorg-x11-server
  • xorg-x11-server-extra: includes Xvfb

The following additional software packages are required:

  • OpenLDAP Client Libraries: includes libldap-2 and openldap2-client
  • SSL Security package: includes openssl and libopenssl-devel

NoteNote:

  • All package versions listed must be at level stated or higher.
  • On x86_64 platforms, if "-32-bit" versions of the above packages are available, they must be installed prior to installing ArcGIS.

6/24/2016