ArcGIS 10.1 for Desktop system requirements

Need info for earlier versions? Click here.

Table of Contents

Supported operating systems

Operating system requirements and limitations

Hardware requirements

Software requirements

License Manager requirements

Developer SDK requirements

Supported operating systems*

Supported Operating Systems

Minimum OS Version

Maximum OS Version

Windows Server 2003 Standard, Enterprise, and Datacenter (32 bit and 64 bit [EM64T])

SP2

SP2

Windows Server 2003 Terminal Services

SP2

SP2

Windows Server 2008 Standard, Enterprise, and Datacenter (32 bit and 64 bit [EM64T])

SP2

SP2

Windows Server 2008 R2 Standard, Enterprise, and Datacenter (64 bit [EM64T])

SP1

Windows Server 2008 R2 with Citrix XenApp 6 and XenApp 6.5**

SP1

SP1

Windows Server 2012 Standard, and Datacenter (64 bit [EM64T])***

Windows 8 Basic, Professional and Enterprise (32 bit and 64 bit [EM64T])***

Windows 7 Ultimate, Enterprise, Professional, Home Premium (32 bit and 64 bit [EM64T])

SP1

Windows Vista Ultimate, Enterprise, Business, Home Premium (32 bit and 64 bit [EM64T])

SP2

SP2

Windows XP Professional Edition, Home Edition (32 bit)

SP3

SP3

Windows XP Professional Edition, Home Edition (64 bit [EM64T])

SP2

SP2

* Please see the Operating system requirements and limitations section for additional requirements and information.

**ArcGIS ArcGIS 10.1 as a hosted application with Citrix XenApp 6 and XenApp 6.5 with Windows 2008 R2 using the Citrix ICA Online Plug-in for Windows 13.1. Please note that ArcGlobe, ArcScene, and any other 3D application generally will not perform well over Remote Desktop or other Windows Terminal Services clients, because these configurations do not support OpenGL 3D graphics acceleration from the server. The Best practices for running ArcGIS for Desktop in a Citrix XenApp environment contains additional information regarding deploying ArcGIS for Desktop with Citrix XenApp.

***Support begins at ArcGIS 10.1 SP1.

Hardware Requirements

Advanced, Basic, Standard

CPU Speed

2.2 GHz minimum ; Hyper-threading (HHT) or Multi-core recommended

Processor

Intel Pentium 4, Intel Core Duo, or Xeon Processors; SSE2 minimum

Run this Microsoft utility from your Windows command prompt to check your processor.

See Dual or dual-core support policy.

Memory/RAM

2 GB minimum

Display Properties

24-bit color depth

Screen Resolution

1024 x 768 recommended minimum at normal size (96 dpi)

Swap Space

Determined by the operating system; 500 MB minimum.

Disk Space

2.4 GB

In addition, up to 50 MB of disk space may be needed in the Windows System directory (typically, C:\Windows\System32). You can view the disk space requirement for each of the 10.1 components in the Setup program.

If using ArcGlobe, additional disk space may be required. ArcGlobe will create cache files when used.

Video/Graphics Adapter

Check your computer's ability to run ArcGIS

64 MB RAM minimum, 256 MB RAM or higher recommended. NVIDIA, ATI, and Intel chipsets supported.

24-bit capable graphics accelerator

OpenGL version 2.0 runtime minimum is required, and Shader Model 3.0 or higher is recommended.

Be sure to use the latest available driver.

Networking Hardware

Simple TCP/IP, Network Card, or Microsoft Loopback Adapter is required for the License Manager.

Software requirements

Printer support

ArcGIS supports printing to any Microsoft certified Windows printer using the native driver in ArcGIS. Please note that some printer drivers do not support complex maps, and the ArcPress printer driver or additional hardware may be needed for these complex maps.

NoteNote:

Esri recommends the following configuration when printing large maps with the ArcPress printer drivers:

  • If large complex maps do not print, then reboot the computer to ensure the pagefile system is cleared. If the pagefile system is not a dedicated drive or partition, make sure that the drive does not need to be defragmented.
  • Disk Space: at least 10 GB of free space is required on the drive where %TEMP% is located, as potentially large temporary files will be written there while ArcPress is processing a map for printing.

For more information on supported printers, please refer to the following Knowledge Base FAQ: What printers are supported by ArcGIS for Desktop?

Software required to connect to a DBMS

Your client machine (for example, the one running ArcMap) will need to have the appropriate client files installed for the RDBMS you are using. These client files are available from their respective RDBMS vendors, but they are also available on Esri Customer Care Portal as a convenience. See Database clients for more information. RDBMS client files available from the customer care portal are IBM DB2, IBM Informix, Oracle, PostgreSQL, and Microsoft SQL Server. Client files for Netezza and Teradata are not available on the customer care portal and must be obtained from the IBM and Teradata support sites.

License Manager ArcGIS 10.1 system requirements

Supported Operating Systems

Minimum Version

Maximum Version

Red Hat Enterprise Linux Server 5 (32 bit and 64 bit)

Update 7 or higher with libX11-1.0.3-11 patch

Red Hat Enterprise Linux Server 6 (32 bit and 64 bit)*

Update 1

Sun Solaris 10 (64 bit [SPARC])*

Maintenance update 4 (8/07)

SUSE Linux Enterprise Server 11 (32 bit and 64 bit)*

SP1

Windows Server 2003 Standard, Enterprise, and Datacenter (32 bit and 64 bit [EM64T]) (including R2)

SP2

SP2

Windows Server 2008 Standard, Enterprise, and Datacenter (32 bit and 64 bit [EM64T])

SP2

SP2

Windows Server 2008 R2 Standard, Enterprise, and Datacenter (64 bit [EM64T])

SP1

Windows Vista Ultimate, Enterprise, Business, Home Premium (32 bit and 64 bit [EM64T])

SP2

SP2

Windows 7 Ultimate, Enterprise, Professional, Home Premium (32 bit and 64 bit [EM64T])

SP1

Windows XP Professional Edition, Home Edition (32 bit)

SP3

SP3

Windows XP Professional Edition, Home Edition (64 bit [EM64T])

SP2

SP2

*OpenGL is required to run the License Server Administrator and the Software Authorization Wizard on these systems.

Hardware requirements for License Manager ArcGIS 10.1 are identical to ArcGIS for Desktop 10.1 hardware requirements.

Developer SDK requirements

ArcGIS for Desktop SDK

Supported and Recommended IDE(s)

SDK Requirements

ArcGIS VBA Resources for Developers

Visual Basic for Applications

ArcGIS for Desktop is required to develop with ArcGIS VBA Resources for Developers.

Microsoft .NET Framework 3.5 Service Pack 1

ArcObjects SDK

ArcObjects SDK requirements

Operating system requirements and limitations

All platforms

Windows

8/11/2014