ArcGIS 10.2.x Web Adaptor system requirements

Table of Contents

Supported application/web servers

Software requirements

Supported browsers

Supported application/web servers

Web Adaptor for IIS:

Application/Web Server

Supported Operating System(s)

Minimum OS Version

Maximum OS Version

IIS 8.5*

Windows Server 2012 R2 Standard and Datacenter*

Update: April 2014**

Windows 8.1 Pro and Enterprise*

Update: April 2014**

IIS 8

Windows Server 2012 Standard and Datacenter

Windows 8 Pro and Enterprise

IIS 7.5

Windows 2008 R2 Server Standard, Enterprise, and Datacenter

SP1

Windows 7 Ultimate, Professional Edition

SP1

IIS 7

Windows 2008 Server Standard, Enterprise, and Datacenter

SP2

SP2

Windows Vista Ultimate, Enterprise, Business

SP2

SP2

IIS 6

Windows 2003 Server Standard, Enterprise, and Datacenter

SP2

SP2

Windows XP Professional Edition

SP2

SP2

*IIS 8.5, Windows 8.1 and Windows Server 2012 R2 support begins at ArcGIS 10.2.1.

**Windows 8.1 and Windows Server 2012 R2 Update: April 2014 support begins at ArcGIS 10.2.2.

  • Windows 8.1, 8, Windows 7, Vista, and XP: These operating systems are supported for basic testing and application development use only. They are not recommended for deployment in a production environment.
  • Microsoft Windows Server 2003, 2003 R2, Vista and XP are no longer supported starting at ArcGIS 10.2.2.

Web Adaptor for Java:

Application/Web Server

Supported Operating System(s)

Minimum OS Version

Maximum OS Version

Tomcat 7

Windows Server 2012 R2 Standard and Datacenter**

Update: April 2014***

Windows Server 2012 Standard and Datacenter

Windows 2008 R2 Server Standard, Enterprise, and Datacenter

SP1

Windows 2008 Server Standard, Enterprise, and Datacenter

SP2

SP2

Windows 2003 Server Standard, Enterprise, and Datacenter

SP2

SP2

Red Hat Enterprise Linux Server 6

Red Hat Enterprise Linux Server 5

Update 7 + libX11 patch*

SUSE Linux Enterprise Server 11

Update 1

Glassfish 3

Windows 2008 R2 Server Standard, Enterprise, and Datacenter

SP1

Windows 2008 Server Standard, Enterprise, and Datacenter

SP2

SP2

Windows 2003 Server Standard, Enterprise, and Datacenter

SP2

SP2

Red Hat Enterprise Linux Server 6

Red Hat Enterprise Linux Server 5

Update 7 + libX11 patch*

SUSE Linux Enterprise Server 11

Update 1

WebSphere 7 (Fixpack 11 minimum)

Windows 2008 R2 Server Standard, Enterprise, and Datacenter

SP1

Windows 2008 Server Standard, Enterprise, and Datacenter

SP2

SP2

Windows 2003 Server Standard, Enterprise, and Datacenter

SP2

SP2

Red Hat Enterprise Linux Server 6

Red Hat Enterprise Linux Server 5

Update 7 + libX11 patch*

SUSE Linux Enterprise Server 11

Update 1

WebSphere 8

Windows Server 2012 Standard and Datacenter

Windows 2008 R2 Server Standard, Enterprise, and Datacenter

SP1

Windows 2008 Server Standard, Enterprise, and Datacenter

SP2

SP2

Windows 2003 Server Standard, Enterprise, and Datacenter

SP2

SP2

Red Hat Enterprise Linux Server 6

Red Hat Enterprise Linux Server 5

Update 7 + libX11 patch*

SUSE Linux Enterprise Server 11

Update 1

Oracle Weblogic 11g Release 1 (v10.3.5 minimum)

NoteNote:
When configuring Weblogic for SSL, see KB 41262.

Windows 2008 R2 Server Standard, Enterprise, and Datacenter

SP1

Windows 2008 Server Standard, Enterprise, and Datacenter

SP2

SP2

Windows 2003 Server Standard, Enterprise, and Datacenter

SP2

SP2

Red Hat Enterprise Linux Server 6

Red Hat Enterprise Linux Server 5

Update 7 + libX11 patch*

SUSE Linux Enterprise Server 11

Update 1

JBoss Application Server 7.1

Windows Server 2012 Standard and Datacenter

Windows 2008 R2 Server Standard, Enterprise, and Datacenter

SP1

Windows 2008 Server Standard, Enterprise, and Datacenter

SP2

SP2

Windows 2003 Server Standard, Enterprise, and Datacenter

SP2

SP2

Red Hat Enterprise Linux Server 6

Red Hat Enterprise Linux Server 5

Update 7 + libX11 patch*

SUSE Linux Enterprise Server 11

Update 1

*Visit Red Hat Support for RHEL 5 Update 7 + libX11 patch information.

**Windows Server 2012 R2 support begins at ArcGIS 10.2.1.

***Windows Server 2012 R2 Update: April 2014 support begins at ArcGIS 10.2.2.

  • Application/web servers and databases are supported on Linux x86_64 and on CPUs that adhere to the x86_64 architecture (64 bit), with supported Linux releases.
  • Microsoft Windows Server 2003, 2003 R2, Vista and XP are no longer supported starting at ArcGIS 10.2.2.

Software requirements

Java support

  • J2SE: Refer to your web server documentation for supported JRE and/or JDK versions.

Microsoft .NET Framework support

  • Web Adaptor for IIS requires Microsoft .NET Framework 3.5 Service Pack 1 (SP1), 4.0, or 4.5 in order to be installed.
  • Each supported version of Microsoft .NET Framework can be downloaded from Microsoft. However, on Windows 7 and Windows Server 2008 R2, Microsoft .NET Framework 3.5 SP1 must be installed using Windows Features.

Follow the instructions below to install version 3.5 SP1 on Windows 7 and Windows Server 2008 R2:

Windows Server 2008 R2

  • Open Server Manager>Features>Add Features. Enable and install Microsoft .NET Framework 3.5.1.

Windows 7

  • Go to Control Panel>Programs and Features>Turn Windows Features on or off. Enable and install Microsoft .NET Framework 3.5.1.

Supported browsers

6/24/2016