PostgreSQL database requirements for ArcGIS 10.2.x

Visit Esri Support for general support information on Esri's Supported Environment Policy as well as information on earlier versions.

Supported database versions

PostgreSQL 9.0.5 (64-bit)

PostgreSQL 9.1.3 (64-bit)

PostgreSQL 9.2.2 (64-bit)

Supported add-ons:

PostGIS 1.5.1

PostGIS 2.0

Supported operating systems

Database

Supported Operating Systems

Minimum OS Version

Maximum OS Version

PostgreSQL 9.0.5 (64-bit)

Red Hat Enterprise Linux Server 5

Update 7 + libX11 patch*

Red Hat Enterprise Linux Server 6

SUSE Linux Enterprise Server 11

SP1

Windows Server 2003 Standard, Enterprise, and Datacenter (64 bit [EM64T])

SP2

SP2

Windows Server 2008 R2 Standard, Enterprise, and Datacenter (64 bit [EM64T])

SP1

PostgreSQL 9.1.3 (64-bit)

Red Hat Enterprise Linux Server 5

Update 7 + libX11 patch*

Windows Server 2008 R2 Standard, Enterprise, and Datacenter (64 bit [EM64T])

SP1

PostgreSQL 9.2.2 (64-bit)

Red Hat Enterprise Linux Server 5

Update 7 + libX11 patch*

Red Hat Enterprise Linux Server 6

Windows Server 2008 R2 Standard, Enterprise, and Datacenter (64 bit [EM64T])

Windows Server 2012 Standard, and Datacenter (64-bit [EM64T])

NoteNote:
Microsoft Windows Server 2003 and 2003 R2 are no longer supported starting at ArcGIS 10.2.2.

*Visit Red Hat Support for RHEL 5 Update 7 + libX11 patch information.

Database requirements/limitations

PostGIS 1.5.1: PostGIS Geometry Spatial Type is supported.

PostGIS 2.0: PostGIS Geometry Spatial Type is supported.

Operating system limitations

Linux

  • ArcSDE application server is only supported on Linux x86_64, on CPUs that adhere to the x86_64 architecture (64-bit), with supported Linux releases.

Required configuration for SUSE 11:

  • With ArcSDE for PostgreSQL and SUSE 11 installation, copy the libpq.so, libpq.so.5, and libpq.so.5.3 libraries from the PostgreSQL library directory to the $SDEHOME/lib directory logged in as sde user first before creating the geodatabase.

Windows

  • PostGIS 1.5.1 does not have a build for Windows 64-bit.
  • PostGIS 2.0 is supported on Windows 64-bit.
  • Windows 7 64-bit is supported for basic ArcSDE application server testing and application development use only. It is not recommended for deployment in a production environment.

Software required to connect to a DBMS

Your client machine (for example, the one running ArcMap) will need to have the appropriate client files installed for the RDBMS you are using. These client files are available from their respective RDBMS vendors, but they are also available on Esri Customer Care Portal as a convenience. See Database clients for more information. RDBMS client files available from the customer care portal are IBM DB2, IBM Informix, Microsoft SQL Server, and PostgreSQL. Client files for IBM Netezza, Oracle and Teradata are not available on the customer care portal and must be obtained from the IBM, Oracle and Teradata support sites.

6/24/2016