ArcGIS 10.2.x Engine system requirements

Visit Esri Support for information on earlier versions.

ArcGIS Engine supported platforms (Windows)

Operating Systems

Minimum OS Version

Maximum OS Version

Windows 8.1 Basic, Pro and Enterprise (32 bit and 64 bit [EM64T])*

Update: April 2014**

Windows 8 Basic, Pro and Enterprise (32-bit and 64-bit [EM64T])

Windows 7 Ultimate, Enterprise, Professional, Home Premium (32 bit and 64 bit [EM64T])

SP1

Windows Vista Ultimate, Enterprise, Business, Home Premium (32 bit and 64 bit [EM64T])

SP2

SP2

Windows XP Professional Edition, Home Edition (32 bit)

SP3

SP3

Windows XP Professional Edition, Home Edition (64 bit [EM64T])

SP2

SP2

Windows Server 2012 R2 Standard, and Datacenter (64 bit [EM64T])*

Update: April 2014**

Windows Server 2012 Standard, and Datacenter (64 bit [EM64T])

Windows Server 2008 R2 Standard, Enterprise, and Datacenter (64 bit [EM64T])

SP1

Windows Server 2008 Standard, Enterprise, and Datacenter (32 bit and 64 bit [EM64T])

SP2

SP2

Windows Server 2003 Standard, Enterprise, and Datacenter (32 bit and 64 bit [EM64T])

SP2

SP2

NoteNote:

Microsoft Windows Server 2003, 2003 R2, Vista and XP are no longer supported starting at ArcGIS 10.2.2.

See the operating system requirements and limitations section for additional requirements and information.

*Support for Windows 8.1 and Windows Server 2012 R2 begins at ArcGIS 10.2.1.

**Windows 8.1 and Windows Server 2012 R2 Update: April 2014 support begins at ArcGIS 10.2.2.

ArcGIS Engine supported platforms (Linux)

Operating Systems

Minimum OS Version

Maximum OS Version

Red Hat Enterprise Linux Server 5 (32 bit and 64 bit)

Update 7 or higher with libX11-1.0.3-11 patch

Latest maintenance update

Red Hat Enterprise Linux Server 6 (32 bit and 64 bit)

Update 1

Latest maintenance update

SUSE Linux Enterprise Server 11 (32 bit and 64 bit)

SP1

Latest maintenance update

See the operating system requirements and limitations section for additional requirements and information.

Hardware requirements

CPU Speed

2.2 GHz minimum ; Hyper-threading (HHT) or Multi-core recommended

Processor

Intel Pentium 4, Intel Core Duo, or Xeon Processors; SSE2 minimum

On Windows: Run this Microsoft utility from your Windows command prompt to check your processor.

See Dual or dual-core support policy

Memory/RAM

2 GB minimum

Display Properties

24-bit color depth

Screen Resolution

1024 x 768 recommended minimum at normal size (96 dpi)

Swap Space

Determined by the operating system; 500 MB minimum.

Disk Space (For Runtime Only)

Windows: 2 GB

Linux: 2 GB

ArcGIS Engine will create cache files when used; additional disk space may be required.

Video/Graphics Adapter

Check your computer's ability to run ArcGIS

64 MB RAM minimum, 256 MB RAM recommended. NVIDIA, ATI, and Intel chipsets supported.

24-bit capable graphics accelerator

Windows: OpenGL version 2.0 runtime minimum is required, and Shader Model 3.0 or higher is recommended.

Linux: OpenGL version 2.0 runtime minimum with Shader Model 2.0 minimum is required, Shader Model 3.0 or higher is recommended.

Be sure to use the latest available driver.

User Interface

Linux: X Windows with Gnome or KDE Desktop Environment is required.

Software requirements

Python Requirement for Geoprocessing

ArcGIS Engine geoprocessing tools require that Python 2.7.x and Numerical Python 1.6.x are installed. If the ArcGIS Engine setup does not find either Python 2.7.x or Numerical Python (NumPy) 1.6.x installed on the target computer, Python 2.7.3 and Numerical Python 1.6.1 will be installed during a complete installation of ArcGIS 10.2. Python 2.7.5 and Numerical Python 1.7.1 will be installed during a complete installation of ArcGIS 10.2.1. You can choose a Custom installation to unselect the Python feature and avoid installing it. Additionally, if the Python setup is executed during the ArcGIS Engine installation, you will be provided with the opportunity to choose its installation location. The Python installation location should not include spaces.

Microsoft .NET Framework Requirement

Windows: Microsoft .NET Framework 3.5 Service Pack 1 must be installed for solutions developed using the Microsoft .NET Framework.

Java Requirement

Java Runtime Environment (JRE) version 6 (32-bit) is required for solutions developed using the Java Platform. Update 20 and above are supported.

Browser Requirement

Windows: Microsoft Internet Explorer, minimum 7 or 8, must be installed prior to installing ArcGIS Engine. Internet Explorer 9, 10 and 11 are also supported.

Linux: ArcGIS Engine requires a minimum installation of the latest version of Mozilla Firefox. If you do not have an installation of Mozilla Firefox, it is recommended you obtain and install it prior to installing ArcGIS Engine.

Software required to connect to a DBMS

Your client machine (for example, the one running ArcMap) will need to have the appropriate client files installed for the RDBMS you are using. These client files are available from their respective RDBMS vendors, but they are also available on Esri Customer Care Portal as a convenience. See Database clients for more information. RDBMS client files available from the customer care portal are IBM DB2, IBM Informix, Microsoft SQL Server, and PostgreSQL. Client files for IBM Netezza, Oracle and Teradata are not available on the customer care portal and must be obtained from the IBM, Oracle and Teradata support sites.

License Manager system requirements

Hardware requirements for License Manager are identical to ArcGIS Engine hardware requirements.

ArcGIS License Manager supported platforms (Windows)

Operating Systems

Minimum Version

Maximum Version

Windows 8.1 Basic, Pro and Enterprise (32 bit and 64 bit [EM64T])*

Update: April 2014**

Windows 8 Basic, Pro and Enterprise (32-bit and 64-bit [EM64T])

Windows 7 Ultimate, Enterprise, Professional, Home Premium (32 bit and 64 bit [EM64T])

SP1

Windows Vista Ultimate, Enterprise, Business, Home Premium (32 bit and 64 bit [EM64T])

SP2

SP2

Windows XP Professional Edition, Home Edition (32 bit)

SP3

SP3

Windows XP Professional Edition, Home Edition (64 bit [EM64T])

SP2

SP2

Windows Server 2012 Standard, and Datacenter (64-bit [EM64T])

Windows Server 2012 R2 Standard, and Datacenter (64-bit [EM64T])*

Update: April 2014**

Windows Server 2008 R2 Standard, Enterprise, and Datacenter (64 bit [EM64T])

SP1

Windows Server 2008 Standard, Enterprise, and Datacenter (32 bit and 64 bit [EM64T])

SP2

SP2

Windows Server 2003 Standard, Enterprise, and Datacenter (32 bit and 64 bit [EM64T])

SP2

SP2

*Support for Windows 8.1 and Windows Server 2012 R2 begins at ArcGIS 10.2.1.

**Windows 8.1 and Windows Server 2012 R2 Update: April 2014 support begins at ArcGIS 10.2.2.

ArcGIS License Manager supported platforms (Linux/UNIX)

Operating Systems

Minimum Version

Maximum Version

Red Hat Enterprise Linux Server 5 (32 bit and 64 bit)

Update 7 or higher with libX11-1.0.3-11 patch

Latest maintenance update

Red Hat Enterprise Linux Server 6 (32 bit and 64 bit)*

Update 1

Latest maintenance update

Sun Solaris 10 (64 bit [SPARC])*

Maintenance update 4 (8/07)

SUSE Linux Enterprise Server 11 (32 bit and 64 bit)*

SP1

Latest maintenance update

*OpenGL is required to run the License Server Administrator and the Software Authorization Wizard on these systems.

Developer SDK requirements

ArcObjects SDK requirements

Operating system requirements and limitations

All platforms

Windows

Linux

6/24/2016