Configuring the ribbon

If you have permissions to create or edit an ArcGIS Map Web Part, you can decide what web part functionality is available to the users of this web part by configuring the ribbon. Configuring the web part ribbon allows you to control which tabs, groups, and tools (buttons) are shown when the web part is not in Edit mode (all tabs, groups, and tools are shown in Edit mode).

Open the Manage Ribbon dialog box

To open the Manage Ribbon dialog box, complete the following steps:

  1. Click the drop-down menu and click Edit Web Part:
    Edit Web Part
  2. Click the Ribbon button located in the Manage group of the web part Application tab. The Manage Ribbon dialog box appears:
    Manage Ribbon dialog box

Show or hide tabs, groups, and tools

By default, only some tabs, groups, and tools are included on the ribbon when the Map Web Part is not in Edit mode. Some of the tools are included on the Application and Layer tabs, and the Symbols tab is not included at all:

Manage Ribbon dialog box

To configure the ribbon, check and uncheck the check boxes in the Manage Ribbon dialog box. The three nodes below the Ribbon Configuration node represent the three tabs that are included with the Map Web Part by default. When you check the check box next to a tab, that tab and all groups and tools within it will be included when the web part is in run mode. When you uncheck the check box and it becomes empty, the tab will be excluded from run mode.

Expanding a tab node will reveal nodes that represent all the groups within that tab. When you check the check box next to a group, the group and all the tools within it will be included in run mode, provided the parent tab is also included. When you uncheck the check box and it becomes empty, the group will not be added to the tab.

Expanding a group node will reveal all the tools within that group. When you check the check box next to a tool, that tool will be included in run mode, provided the parent group and tab are also included. When you uncheck the check box, the tool will not be included.

In the following example, some of the tools are included in the Application tab, all the tools within the Layers tab are included, and the Symbols tab is not included:

Ribbon check boxes

The following image shows the Application tab group nodes. Some of the tools within the Map group are included, all of the tools within the Attribute Table group are included, and the Theme, Manage, and View groups are not included:

Tab check boxes

The following image shows the Configure group tool nodes. The Transparency, Pop-Ups, and Table tools are included, and the Filter and Open item on click tools are excluded:

Groups check boxes

Add a tab

To add a tab, complete the following steps:

  1. In the Manage Ribbon dialog box, select the Ribbon Configuration (root) node, then click the Add button:
    Manage Ribbon dialog box
    The Add New Tab dialog box appears.
  2. Type a title and a tooltip and click OK:
    Add New Tab dialog box
  3. Click the OK or Apply button in the properties pane to the right of the web part:
    ArcGIS Map Web Part properties pane
    When the web part loads, the new tab will be included on the ribbon:
    New tab added to ribbon

Remove a tab

To remove a tab, complete the following steps:

  1. In the Manage Ribbon dialog box, select the tab to remove:
    Remove tab
  2. Click the Remove button. The Confirm delete dialog box appears.
  3. Click OK:
    Confirm delete dialog box
  4. Click the OK or Apply button in the properties pane to the right of the web part:
    ArcGIS Map Web Part properties pane
    When the web part loads, the tab will no longer be included on the ribbon.

Change tab order

To change the tab order, complete the following steps:

  1. In the Manage Ribbon dialog box, select the node corresponding to the tab you want to move. The appropriate Move Up and/or Move Down buttons will become enabled.
  2. Click the desired arrow to move the tab:
    Change tab order
    The tab is moved in the direction you selected.
  3. Click the OK or Apply buttons in the properties pane to the right of the web part:
    ArcGIS Map Web Part properties pane
    When the web part loads, the tab order will be updated as specified:
    Tab order changed on ribbon

Edit a tab

To edit a tab, complete the following steps:

  1. In the Manage Ribbon dialog box, select the node corresponding to the tab you want to edit.
  2. Click the Edit button:
    Edit tab
    The Edit Tab dialog box appears.
  3. Edit the title and tooltip as desired and click OK:
    Edit Tab dialog box
  4. Click the OK or Apply button in the properties pane to the right of the web part:
    ArcGIS Map Web Part properties pane
    When the web part loads, the tab's title and tooltip will be as specified in the Edit Tab dialog box.

Add a group

You can add groups to any tab, regardless of whether or not it is one of the defaults. To add a group, complete the following steps:

  1. In the Manage Ribbon dialog box, select the node corresponding to the tab where you want to add the group.
  2. Click the Add button:
    Add group
    The Add New Group dialog box appears.
  3. Type a title and a tooltip and click OK:
    Add New Group dialog box
    NoteNote:
    If you add a group and do not add tools to that group, the group will not be saved. See the Add a tool section below for information on how to add a tool.
  4. Click the OK or Apply button in the properties pane to the right of the web part:
    ArcGIS Map Web Part properties pane
    When the web part loads, the new group will be included in the specified tab on the ribbon.

Remove a group

To remove a group, complete the following steps:

  1. In the Manage Ribbon dialog box, select the group to remove.
  2. Click the Remove button:
    Remove group
    The Confirm delete dialog box appears.
  3. Click OK:
    Confirm delete group
  4. Click the OK or Apply button in the properties pane to the right of the web part:
    ArcGIS Map Web Part properties pane
    When the web part loads, the group and its tools will no longer be included on the ribbon.

Change group order

To change the group order, complete the following steps:

  1. In the Manage Ribbon dialog box, select the group to move. The Move Up and/or Move Down buttons will be enabled as appropriate.
  2. Click the desired arrow to move the group:
    Change group order
  3. Click the OK or Apply button in the properties pane to the right of the web part:
    ArcGIS Map Web Part properties pane
    When the web part loads, the order of groups on the ribbon will be updated to reflect the change.

Edit a group

To edit a group, complete the following steps:

  1. In the Manage Ribbon dialog box, select the group to edit.
  2. Click the Edit button:
    Edit group
    The Edit Group dialog box appears.
  3. Edit the group's title and tooltip as desired and click OK:
    Edit Group dialog box
  4. Click the OK or Apply button in the properties pane to the right of the web part:
    ArcGIS Map Web Part properties pane
    When the web part loads, the group's title and tooltip will be as specified on the Edit Group dialog box.

Add a tool

To add a tool, complete the following steps:

  1. In the Manage Ribbon dialog box, select the group where you want to add the tool.
  2. Click the Add button:
    Add control button
    The Add New Control dialog box appears.
  3. Select the tool to add from the Tool drop-down menu. You can also change the label, add a tooltip, and change the icon if desired.
  4. Click OK:
    Add New Control dialog box

    For more information about the tools that appear in this drop-down menu, see Uploading add-ins.

    If you are adding a geoprocessing tool or another tool that provides additional configuration options, you can click the Configure button to set up the tool. For more information about configuring geoprocessing tools, see Adding Geoprocessing tasks.

  5. The new tool will appear in the Manage Ribbon dialog box. To make the new tool available to your users, make sure the check box next to it is checked:
    Add control checked
  6. Click the OK or Apply button in the properties pane to the right of the web part:
    Edit map web part
    When the web part loads, the new tool will be included on the ribbon.

Remove a tool

To remove a tool, complete the following steps:

  1. In the Manage Ribbon dialog box, select the tool to remove.
  2. Click the Remove button:
    Remove control
    The Confirm delete dialog box appears.
  3. Click OK:
    Confirm delete dialog box
    The tool will immediately be removed from the list of tools in the Manage Ribbon dialog box.
  4. Click the OK or Apply button in the properties pane to the right of the web part:
    ArcGIS Map Web Part properties pane
    When the web part loads, the tool will no longer be included on the ribbon.

Change tool order

To change the tool order, complete the following steps:

  1. In the Manage Ribbon dialog box, select the tool to move. The Move Up and/or Move Down buttons are enabled as appropriate.
  2. Click the desired arrow to move the tool:
    Change order control
  3. When the tool is positioned as desired, click the OK or Apply button in the properties pane to the right of the web part:
    Edit map web part
    When the web part loads, the tool's position on the ribbon will be updated to reflect the changes made on the Manage Ribbon dialog box.

Edit a tool

To edit a tool, complete the following steps:

  1. In the Manage Ribbon dialog box, select the tool to edit.
  2. Click the Edit button:
    Edit control
    The Edit Control dialog box appears.
  3. Change the label, tooltip, icon, or additional configuration as desired and click OK:
    Edit Control dialog box
  4. Click the OK or Apply button in the properties pane to the right of the web part:
    Edit map web part
    When the web part loads, the tool will reflect the changes that were made.

11/30/2012