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» Download items

» Set up a new project

« First street layout

» Navigation and selection

* Model generation with rules

* Rule editing

* Tutorial data

* Tutorial PDF

First, you'll create a new CityEngine project.

Steps:

1. Click File > New > CityEngine > CityEngine project.
The Select a wizard dialog box appears.

] New LIEI_J&
Select a wizard —

Create a CityEngine project folder,

Wizards:
type filter text

(= General

= CityEngine
&%) CGARuleFile
1&g CityEngine project
= CityEngine scene
= City Wizard

== Python

[ Show All Wizards.

< Back Mext = Finish

%

2. Click Next, name your project MyFirstCity, and click Finish.
A new project is created and appears in the Navigator (by default, located in the upper left corner of the CityEngine
window). The default folders that store your project data, such as assets, rules, and scenes, are already present, though
empty.

Next, you'll create a new scene.

3. Click File > New > CityEngine > CityEngine scene.
The CityEngine Scene dialog box appears.
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e (B

CityEngine Scene

This wizard creates a new CityEngine scene file,

Project folder: MyFirstCity/scenes

File name: myFlrstC\ty_UllceJ

Coordinate Systemn:

Finish ] [ Cancel

Copy rules and assets

Later in this tutorial, you'll need rule files and assets for the generation of the building models. You copy these files from the main
Tutorial 1: Essential Skills project, which you should already have linked to your workspace.

Now you'll copy all necessary files from the downloaded Tutorial 1 project into your new project.

Steps:

1. Use copy paste (Windows and Linux: Ctrl-C and Ctrl-V/Mac OS: Command-C and Command -V) on your keyboard or
from the right mouse button context menu.

Navigator &3 =8

4 =% MyFirstCity
= assets
= data
= images
= maps
= models
= rules

4 (= scenes
= myFirstlity 031cej
= scripts

4 1= Tutorial 01_Esseati

4 [= assets
» = window
|| shopwin.

_Skills

S

|| wall.tif
= data
= images
= maps
= models
a = rules
&%/ building_02.cga
&%| building.cga
4 [~ scenes

= Essential l.cgj

[= scripts

2. Copy the contents of both the assets and rules folders.
Your Navigator should look like the following screen shot:

Copyright © 1995-2015 Esri. All rights reserved.



Tutorial 1: Essential skills

Navigator &3

4 [ MyFirstCity
4 = assets
b (& window
& shopwin.tif
& wall tif
(= data
(= images
(= maps
= models
4 (= rules
% building_02.cga
&%) building.cga
(& scenes
= myFirstCity 01.cej
(= scripts
4 1= Tutorial 01_Essential_Skills
4 = assets
b = window
& shopwin.tif
& wall.tif
(= data

(= images

& maps

= models

4 [ rules

&%) building_02.cga
% building.cga

(& scenes

(= scripts

First street layout

Random street grow
After the new project has been set up, you're ready to start creating the first street layout in your newly created scene.
First, you'll create a street network.
Steps:
1. Click the viewport to make it the active window.

2. Click Graph > Grow Streets.
The Grow Streets dialog box appears.
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= =)

Grow Streets

Different street patterns can be combined to generate
typical street networks.

Precet:
! ~ [+2) (&) (]

' Advanced Settings

A Basic Settings

Number of streets 500 -
Pattern of major streets
Pattern of minor streets [RASTER v]
Long length 150.0

Long length deviation 500

Short length 80.0

Short length deviation 200

“ Environment Settings
“ Pattern Specific Settings

W Street Width Settings

[ mppy ]| close

3. Keep the default settings for now.
4. Click Apply, and close the dialog box.
Approximately 500 streets were created, but you can't see them all in the viewport until you frame the view.

5. Press the A key to frame all objects in the viewport. Your viewport should look similar to the following screen shot:

‘VIE’WPDHE@ |i§jﬁi'ﬁ'*'mﬁ.

Your Scene Editor should now contain a new Streetnetwork layer, containing a network of blocks, graph segments, and
shapes. It should look similar to the following screen shot:
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= Scene =g

»  search expression

& @ Panorama
4 &G’\ Streetnetwork (1071 Objects)

m

Shape
Shape
Shape
Shape
Shape
Shape
Shape

olotalelolcto gy

Block

Navigation and selection

Navigation

Navigating in the viewport is one of the most essential skills a CityEngine user has to master. This section looks at the different
navigation schemes available.

Steps:
1. Click Edit > Preferences > General > Navigation Devices > Mouse.

The Current Mouse Scheme drop-down menu lists the available schemes of other 3D apps.

S Pt e
type filter text Mouse 2 T
Export Current Mouse Scheme -
4 Genersl Sl
Appearance CityEngine® Default r
Compare/Patch
ditors Tool / Select m + [None]
Keys
Miscellaneous Track / Seroll m + [A]
4 Mavigation Devices
30 Mouse Tumble / Rotate m + [Al]
Mouse
Touch Delly / Zoom m - [AR]
Perspectives
Drocedural Runtime Selection Replace Modifiers [Mone]
Search 3
e Selection Add Medifiers [Shift]
Viewpart
|
Help Selection Invert Madifiers [Cerl)
Network
Python Selection Subtract Modifiers [Cel] [Shift]
Reset Preferences
Scene Tool Madifiers (Snap, etc.) [Shift]
Secondary Tool Modifier [Ctrl]

=\ Note: For those who have a 3D Connexion 3D Mouse (http://www.3dconnexion.com/), there are specific
preferences for that.
You'll focus on the default navigation scheme. The options are shown in the following table:

Navigation command Windows and Linux keyboard shortcut Mac OS keyboard shortcut
Tumble the view Alt+left mouse button Option+ Imb

Pan the view Alt+middle mouse button Option+mmb

Zoom Alt+right mouse button (or use the mouse wheel) Option+rmb

ﬁa Tip: » For efficient navigation of the constant use of the frame key F, use the frame button in the

viewport’s toolbar.
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To interact and edit the objects in your scene, you need to select them. Start the Selection Tool using the mouse button or (press the
Q key). Select the objects by clicking in the viewport.

=\ Note: The F9-F12 keys toggle the visibility of the four main object types: Map Layers, Graph Segments,
Shapes, and Models. Deactivating the visibility of other object types usually simplifies making proper
selection.

Selection types

The selection types are described in the following table:

Selection type Result
Single click Selects a single object
Right-to-left rectangular selection Selects all objects inside or touching the selection rectangle
Left-to-right rectangular selection Selects all objects completely within the selection rectangle

The left-to-right rectangular selection is usually used to select tiny objects such as single Street Graph Nodes when there are many
objects occupying the same space.

Modifier keys

The Ctrl and Shift keys toggle the different selection modes. The modes are also listed in the Select Tool submenu in the toolbar.

Selection context menu

Once you have a selection, the right mouse button context menu contains entries with which you can select additional elements.

3D Mouse
R Sebect C Select All
Deselect A1l Ciri+Shifte A

CrrdeA

Invert Selection

WTH

Convert to Static Shapes
Select Objects in Same Layer

Select Objects by Map Layer »

Select Objects of Same Type

\ Il
Q Assign Rule File... Select Objects of Same Group
W% Generate CirlsG Select Objects with Same Rule File
o Update Seed and Generate Ctrl+Shift«G Select Objects with Same Stan Rule
Delete Model:
elete Modes Apply Selection Set o |
Reset Seed e

&%  Edit Selection Sets...

s T~ TT T 1T ——

FAEET A

The selection items are described in the following table:

Selection mode Selection element(s)
Select Objects of Same Type Types: shapes, graph nodes
Select Objects of Same Group: In the same block/street
Select Objects with Same Rule File Same rule file assigned (on all visible layers)
Select Objects with Same Start Rule: Same start rule (on all visible layers)

CityEngine is a procedural modeling application. This means that CityEngine uses rules to generate the 3D model.
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Model Generation

Modeling
Procedure

Input Geometry ﬂ @ Resulting 3d Model
u l : l \ﬁ‘

Assign rules
In this tutorial, the rules are already provided. You'll use them now.

Steps:

1. Select one block, and change its subdivision parameters in the Inspector from Recursive Subdivision to Offset
Subdivision as shown in the following screen shot:

A Block Paramaten

shapelremion ] true (Defaut) 2 - G

] Offset Sabdivisi |
clfartiideh ] 25 (Detanit) — d
subdivinieflucor... 1] true (Dafauit) on ® o

Iethreatiin €] 500 Detauk] e s
Iethreabtax ) 1500 Defa] e
leiicbbin ] 10 Defanit) L -
eguiscty ] 03 ety *

forcebiresshcoess ] 0 (Defaulty &

slignment ) Uneves [Defaul)  Uneven =
—.—

(SR

v Dtiect st
'Select Block o=

For more information on block subdivision and dynamic city layouts, see Tutorial 2: Terrain and dynamic city layouts.
2. Select one shape within the block, and use the context menu to Select Objects of Same Group.

3. Drag and drop the building.cga rule file onto the selected shapes (highlighted orange).
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=0

7| Mavigator 2 = 0| @ viewport 22
B85 ([ESs~
4 [ MyFirstCity
4 (= assets
b = window
|&| shopwin.tif
|| wealltif
(= date
&= images
1= meps
(= models
4 = rules
&F building 02.cqs

| building.cga/

= scripts
b = Tutorial 01_Essential_Skills

= *Scene 8 =8
v search expression

W Scene Light
4 & Pancrama
b Frw Steetnetwork (1071 Objects)

| [ k

After dropping the rule onto the shapes, the model generation is automatically started. Your first buildings appear. Make

sure the visibility of models is activated by toggling with E12.

S[E[P[B) & & & - £~ k-~ O

Generated models can also be deleted in the right mouse button context menu.
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4. Select the footprint shape again, and click Ctrl+G (Mac OS: Command+G) or use the Generate button on the toolbar to

6.

3D Mouse

Select

£% Grow Streets,

Cenvert Models to Shapes
Toggle Inspect Model /

e
& Assign Rule File...
F Generate Ctr+G
% Updste Seed and Generate Ctrl+ Shift+ G

Delete Models s

Reset Seed
—

I/l

[y

generate the model on the selected shape.
New variations of the buildings can be created by changing the seed value.

Use the Update Seed and Generate new Model button on the toolbar or click Ctrl+Shift+G (Mac OS:
Command+Shift+G).
The following image shows an example of different seed values:

EEHW - -0 g EEEE & W8 w- T EEEH o -0

Manually edit the rule’s building height parameter in the Inspector:

€ Viewpont i 2R S &0 B & - LE - ke 7O @ specter 12 =
2 v | 489 e Fo : ) £ shape
Name Shape

“ Shape Parameters

# Rules

Buls Fils building.cga Assign..
Start Rula Let L Select...
A bullding Default Style... |4 |
floorheight 4] 4 (Ruls) &>

.
shapeType  #] Lot (Object)

tiewidth %] 3 {Rule) °

windowkeight ] 25 (Rule) @

windowWidth ] 2.2 (Rule) *

¢ Reports

v Object Attributes

streetWidthiD) 15150851 -

strestWidthil) 15150851 -

streetWidthi2) 11829317 @

streetWidth3) 11829317 &

streatWidth(4) 0 &

StreatVidths) 0 &

shapeType Lot

W Vertices

" Information

Once you manually change attributes in the Inspector it will become bold and override the definitions of the rule.
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Reset the attributes to the building.cga rule definitions by right-clicking the arrow next to the attribute in the Inspector
and choosing Reset user attributes.
-

fioorheight  *0 4

neight () ¥ e mneee 2
snapeType . A+ Create new style.

tilewidth ¥ (@) Reset user attributes
windowHeig-. % Reset all attributes
windowWidth € 2.2 @

CityEngine’s rule system uses CGA code, a dedicated scripting language unique to CityEngine. Because CGA is a scripting

language, it offers you a generic and flexible tool to create 3D models for all types of cities. From modern to contemporary, from
ancient to futuristic, anything’s possible.

Explore the provided rule you've been using so far.

Steps:
1.

Open the building.cga rule in the Rule Editor by either double-clicking the CGA rule file in the Navigator or using the
Rule File link in the Inspector.

O inspector 2 =g
£ Shape
Mame Shape

“ Shape Parameters

# Rules
Bule File building.cga T
Start Rule Lot

2. Start editing the building.cga rule in the Rule Editor.

=

= & buildingcga

{15,25)

Steps:

1. Inspect building.cga rule. the Height is defined as a random value between 15 and 25.

attr height = rand(15,25)
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LZEX e BIE LoGnnte i d *a
€ Viewport 2EP[P o He i k=0 B
Purspectva View | 4375 Gojocts (¢ seisc irgons (5256 swlacted) & shape

Name Shape
“ Shape Parameters

~ Rules

Buls File building.cga Assign...
Start Rule Lot Setect.
~ building Defaukt Style... | +
floorheignt % 4 @

= | height < 22824597 @

ShapeType

tilewidth % 3 @
windowHeig.. ] 28 *
windowWidth € 22 @

v Reports
v Object Attributes
¥ Vertices

~ Information

= 3
No operations to display at this time.

The building has a random height value of 22.82.

2. Change the random height values in the Rule Editor.
attr height = rand(15,80)

The height is now defined as a random value between 15 and 80.
3. Save the rule.

4. Regenerate the building by clicking the Update Seed and Generate Models button g cenerate [@] or pressing Cntrl + Shift
+ G on your keyboard.

453 e BYE €Ocenente B0 &

€ Viewport I SHPS s HE~ 00
Paeipective View | 4975 Obcts (2 sélectsd) | 71066 Polygons (17056 selecied) & Shape

Name ‘Shape
~ Shape Parameters

A Rules

Rule File building<ga Assign..
M| start Rule. Lot Select..
A building Defoult Style.. | +
flootheight & 4 -

e [height = 7201874 [l |
% shapeType ©

tilewidth o3 *
windowHeig_. '€l 28 *
windowWidth & 22 @

~ Reports
~ Object Attributes
~ Verices

W Information

5 Progress I &
No operations to display at this time.

168

The building now has a random height value of 72.02.

= Note: The reason you use the Update Seed and Generate Models button @ cenerate @ is because
the height is a random value and you need to update the random seed value when
regenerating the building.

5. Add roof geometry by adding a new Rule named Roof to the building.cga rule. To do this, do the following:
a. Edit the Lot rule so it looks like this:
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Lot -->
case shapeType == "LotInner" :
Lot.

else :
extrude (height) comp(f) { side : Facade | top: Roof }

b. Add the Roof rule and define the shape as roofHip with an angle of 22.5 degrees..

Roof --> roofHip(22.5) Shape

c. Save the rule.

6. Regenerate the building, but this time, click the Generate Models button % Generate Or press Cntrl + G on your
keyboard. By doing this, you will keep the building height at 72.02 and see the new roof geometry.
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