Need info on 1.x system requirements? Please click here.

ArcGIS Web APIs 2.x Supported Browsers

Browers supported with applications developed with ArcGIS Web APIs.

 

Web Browser Flex API JavaScript API Silverlight API
Firefox 3.5 or higher
Google Chrome 4 or higher
Internet Explorer 7
Internet Explorer 8
Internet Explorer 9*
Safari 3 or higher

*Support begins at Flex API 2.3.1, JavaScript API 2.3, and Silverlight API 2.2.

Required Browser Plug-Ins

  • Adobe Flash Player 10: Required for viewing applications developed with the ArcGIS API for Flex.
  • Microsoft Silverlight 4: Required for viewing applications developed with the ArcGIS API for Silverlight.
Filed under:

ArcGIS Web APIs 2.x Development Requirements

ArcGIS API for Flex

ArcGIS API for Silverlight/WPF

  • Microsoft Visual Studio 2010 (Professional or Standard Editions)
  • Microsoft Visual Web Developer Express 2010
  • Microsoft Expression Blend 4 (All Editions) or Microsoft Expression Blend 4 SDK
  • Silverlight 4 Tools for Visual Studio 2010
  • Silverlight 4 (Browser Plug-in)
    See the System Requirements tab on the Silverlight site for more details.  
Filed under: