Supported Database Versions

PostgreSQL 8.3.8 (32-bit)
PostgreSQL 8.3.8 (64-bit)
PostgreSQL 8.4.1 (32-bit)
PostgreSQL 8.4.1 (64-bit)
Supported Add-On: PostGIS 1.4.0

Supported Operating Systems

Database Supported Operating System(s) Minimum OS Version Maximum OS Version
PostgreSQL 8.3.8 (32-bit) Red Hat Enterprise Linux Server 5 (32-bit) Update 5 Update 5
SUSE Linux Enterprise Server 10 (32-bit) SP3 SP3
Windows Server 2003 Standard, Enterprise & Datacenter (32-bit) SP2 SP2
Windows Server 2008 Standard, Enterprise & Datacenter (32-bit) SP2 SP2
Windows Server 2008 R2 Standard, Enterprise & Datacenter (64-bit (EM64T))    
PostgreSQL 8.3.8 (64-bit) Red Hat Enterprise Linux Server 5 (64-bit) Update 5 Update 5
SUSE Linux Enterprise Server 10 (64-bit) SP3 SP3
PostgreSQL 8.4.1 (32-bit) Red Hat Enterprise Linux Server 5 (32-bit) Update 5 Update 5
SUSE Linux Enterprise Server 10 (32-bit) SP3 SP3
Windows Server 2003 Standard, Enterprise & Datacenter (32-bit) SP2 SP2
Windows Server 2008 Standard, Enterprise & Datacenter (32-bit) SP2 SP2
Windows Server 2008 R2 Standard, Enterprise & Datacenter (64-bit (EM64T))    
PostgreSQL 8.4.1 (64-bit) Red Hat Enterprise Linux Server 5 (64-bit) Update 5 Update 5
SUSE Linux Enterprise Server 10 (64-bit) SP3 SP3

Limitations

Linux
ArcSDE for PostgreSQL is only supported on:

  • Linux x86, on CPUs that adhere to the x86 architecture (32-bit), with supported Linux releases.
  • Linux x86_64, on CPUs that adhere to the x86_64 architecture (64-bit), with supported Linux releases.

Required Configuration for SUSE 10:

  • With ArcSDE for PostgreSQL and SUSE 10 installation, copy the libpq.so, libpq.so.5, and libpq.so.5.1 libraries from the PostgreSQL library directory (/usr/local/pgsql/lib) to the $SDEHOME/lib directory logged in as sde user first before executing 'sdesetup -o install' to create the geodatbase.

ArcSDE for PostgreSQL is not supported on Red Hat 4.  This includes direct connections from client applications installed on Red Hat 4, such as ArcGIS Server and ArcGIS Engine.

Windows
ArcSDE for PostgreSQL is currently only supported as a 32-bit application.

Windows XP SP3 Professional Edition
Windows XP Service Pack 3 is supported for basic testing and application development use only. It is not recommended for deployment in a production environment.

Filed under: