Need info for earlier versions? Please click here for ArcGIS Engine Developer Solutions. Click here for ArcGIS Desktop Developer Solutions.

Table of Contents
Supported Operating Systems
Operating System Limitations
Hardware Requirements
Developer Solutions (SDK) Requirements

Supported Operating Systems

Supported Operating System Minimum

Version
Maximum

Version
ArcObjects SDK
for the Java Platform
ArcObjects SDK
for Cross Platform C++
ArcObjects SDK
for the Microsoft .NET Framework
Red Hat Enterprise Linux AS/ES/WS 4 (32-bit and 64-bit) Update 4 or higher   Supported Supported Not Supported
Red Hat Enterprise Linux Server 5 (32-bit and 64-bit) Base or higher   Supported Supported Not Supported
SUSE Linux Enterprise Server 10 (32-bit and 64-bit) SP2   Supported Supported Not Supported
Sun Solaris 10 (64-bit (SPARC)) Maintenance Update 4 (8/07) or higher   Supported Supported Not Supported
Windows 2003 Server Standard, Enterprise & Datacenter (32-bit and 64-bit (EM64T)) SP2 SP2 Supported Supported Supported
Windows 2008 Server Standard, Enterprise & Datacenter (32-bit and 64-bit (EM64T))   SP2 Supported Supported Supported
Windows 2008 R2 Server Standard, Enterprise & Datacenter (64-bit (EM64T))    SP1* Supported Supported Supported
Windows 7 Ultimate, Professional, Home Premium (32-bit and 64-bit (EM64T))    SP1* Supported Supported Supported
Windows Vista Ultimate, Enterprise, Business, Home Premium (32-bit and 64-bit (EM64T)) SP2 SP2 Supported Supported Supported
Windows XP Professional Edition, Home Edition (32-bit) SP3 SP3 Supported Supported Supported
Windows XP Professional Edition, Home Edition (64-bit (EM64T)) SP2 SP2 Supported Supported Supported

 *Support begins at ArcGIS 10 service pack 2.

Hardware Requirements

Disk Space Requirements

  Microsoft Windows Red Hat Linux SUSE Linux Sun Solaris
ArcObjects SDK for the Java Platform 655 MB 695 MB 695 MB 690 MB
ArcObjects SDK for Cross Platform C++ 421 MB 566 MB 566 MB 670 MB
ArcObjects SDK
for the Microsoft .NET Framework
989 MB Not Applicable Not Applicable Not Applicable

 

Developer Solutions (SDK) Requirements

ArcObjects SDK Supported and Recommended IDE(s) SDK Requirements
ArcObjects SDK for the Java Platform All Platforms

Developer IDE plug-ins, which offer an enhanced developer experience through templates, code snippets, and project wizards, are provided with the ArcObjects SDK for the Java Platform, and are supported in the IDEs listed below: (NOTE: Visual beans users must manually install Visual Editor.)
  • Eclipse Galileo IDE for Java EE Developers
  • Eclipse Galileo IDE for Java Developers
  • Eclipse Ganymede IDE for Java EE Developers
  • Eclipse Ganymede IDE for Java Developers

 

ArcGIS Desktop, ArcGIS Engine Runtime or ArcGIS Server is required to develop with the ArcObjects SDK.

 

Java Development Kit (JDK) version 6 update 16 (32-bit)

ArcObjects SDK for the Microsoft .NET Framework

Microsoft Visual Studio 2008 SP1 Visual Basic Express

Microsoft Visual Studio 2008 SP1 Visual C# Express

Microsoft Visual Studio 2008 SP1 (C#, VB.NET) Standard, Professional, Team Edition

Microsoft Visual Studio 2010 (C#, VB.NET) Professional, Premium, Ultimate Edition

ArcGIS Desktop, ArcGIS Engine Runtime or ArcGIS Server is required to develop with the ArcObjects SDK.

 

Microsoft .NET Framework 3.5 SP1

ArcObjects SDK for Cross Platform C++

Windows: Visual Studio 2008 SP1 (C++) Standard, Professional, or Team Editions; Microsoft Visual Studio 2010 (C++) Professional, Premium, Ultimate Edition
Linux: g++ 3.4.6 or 4.1.2
Solaris:
Sun Studio 11 or 12 (C++ 5.4 or 5.5)

 

Supported and recommended Widget Toolkit(s)

NOTE: Only the Qt Commercial License is supported.

  Windows Linux Solaris
Motif Not Applicable 2.2.3 2.1.0
GTK 2.4.14 2.4.13 2.4.9
QT3 3.3.8 3.3.8 3.3.8
QT4 4.2.3 4.2.3 4.2.3
WX 2.8.7 2.8.7-GTK 2.8.7-GTK

ArcGIS Engine Runtime is required to develop with the ArcObjects SDK.

 

Windows: Microsoft .NET Framework 3.5 SP1

 

Operating System Limitations

All Platforms

When running in a 64-bit environment, ArcGIS Desktop, ArcGIS Server, ArcGIS Engine, and ArcReader run as a 32-bit application.  See Does ESRI support 64-bit processors with ArcGIS 10.0 products?

Filed under:

Operating System Limitations - Windows

  • ArcGIS Developer Help System on Windows 7 requires Adobe Reader 9.1.2 or higher. See KB37244 for more details.
  • ArcGlobe/ArcScene, and any other 3D application generally will not work over Remote Desktop or other Windows Terminal Services clients, because they do not support 3D graphics acceleration.
Filed under:

Operating System Limitations - Linux

The Linux releases of ArcGIS Engine-related products are only supported on CPUs that adhere to the x86 architecture. Esri only supports the following Linux operating systems, whose releases are designated by their respective vendors as "Generally Available", "Production", "Fully Supported" or equivalent (not "Beta" or derivative /binary compatible distributions).

 

Red Hat Linux 4

The Linux patches for Red Hat Enterprise Linux (RHEL) 4 Update 4 minimum AS/ES/WS will be supported as long as the patches are from Red Hat without any modification to the latest kernel/glibc version.

The following package groups are required:

  • The Base System > X Window System Package Group (standard packages sufficient)
  • From the Development Group:
    • Development Tools Package,  including the gcc-g77 package from the Extra Packages section. (Note: The required library libg2c.so.0 is owned by the libf2c package; the libf2c package is provided by the gcc-g77 package.)  
    • Legacy Software Development Package (standard packages sufficient)
    • X Software Development Package

The following additional software packages are required:

  • cario
  • compat-libstdc++-33
  • compat-libstdc++-296
  • compat-libgcc-296
  • compat-libf2c
  • compat-openldap-2.1.30-12
  • freeglut
  • gmp
  • gtk2-2.4.13 and gtk2-devel-2.4.13
  • GNU C Library glibc 2.3.4-2
  • libidn
  • OpenGL Packages: mesa-libGL and mesa-libGLU
  • openldap
  • openmotif and openmotif-devel
  • openssl
  • xorg-x11-Xvfb-6.8.2-1

Note:

  • All package versions listed must be at level stated or higher.
  • For 64-bit OS support, if 32-bit versions of the above packages are available, they must be installed prior to installing ArcGIS.

Red Hat Linux Server 5

The Linux patches for Red Hat Enterprise Linux (RHEL) Server 5 (32-bit and 64-bit) will be supported as long as the patches are from Red Hat without any modification to the latest kernel/glibc version.

NIS Client Limitation: ArcGIS installation hangs while registering libmwxml.so from a network client on Linux RedHat Version 5. See KB37541 for more details.

The following package groups are required: 

  • The Base System  > X Window System - all package groups
  • The Base System > Legacy Software Support Group, including the following from Optional Packages:
    • compat-libstdc++-33
    • compat-libstdc++-296
    • compat-libf2c
    • compat-libgcc-296
    • compat-openldap-2.3
  • The Development > Development Tools - all package groups
  • The Development > Legacy Software Development - all package groups
  • The Development > X Software Development - all package groups

The following additional software packages are required:

  • cairo
  • compat-libf2c-34
  • compat-gcc-34
  • freeglut-2.4
  • GNU C Library (glibc) 2.3.4
  • gmp
  • gtk2-2.10 and gtk2-devel-2.10
  • libidn
  • OpenGL packages: mesa-libGL and mesa-libGLU
  • Openldap package: openldap
  • openmotif and openmotif-devel
  • Openssl package: openssl

Note:

  • All package versions listed must be at level stated or higher.
  • For 64-bit OS support, if 32-bit versions of the above packages are available, they must be installed prior to installing ArcGIS.

SUSE Linux Server 10

The Linux patches for SUSE Linux Enterprise Server (SLES) 10 SP2 minimum will be supported as long as they are from SUSE Linux without any modification to the latest kernel/glibc version.

The following software packages are required:

  • From Development > Languages > Fortran Package Group
    • libg2c33 package (Note: This package is available as patch GNU G77 20081203 from Novell. See KB35105 for more details.)
  • From System > Libraries Package Group
    • compat packages
    • freeglut package
    • Mesa packages
  • From System > X11 > Utilities Package Group
    • The X Window System Group (xorg-x11)

The following additional software packages are required:

  • GNU C Library (glibc) version 2.3
  • gmp
  • gtk2-2.8.11 and gtk2-devel-2.8.11
  • libidn
  • OpenLDAP Client Utilities
  • openmotif and openmotif-devel
  • openssl-0.9.8a
  • Patch for Xserver Xvfb  (xorg-x11-server-extra). (Note: This is a hardware-independent Xserver, which can be installed from XFree86-Xvfb-4.3.99.902-43.22.i586.rpm, which comes with SLES 10.)

Note:

  • All package versions listed must be at level stated or higher.
  • For 64-bit OS support, the 32-bit versions of the above packages must be installed prior to installing ArcGIS.
  • To make a Direct Connection from ArcGIS Engine Runtime on SUSE to ArcSDE for PostgreSQL, please see the Esri Knowledge Base Article KB38606 for details. 

 

Operating System Limitations - Solaris

It is a requirement that the OS (binary) has not been modified. Esri does not provide any support if products are installed on Developer's Release of an Operating System.

Sun Solaris 10

  • The following are required:
    • Solaris Maintenance Update 4 (dated 8/07) minimum or higher
    • 113886-29 patch for OpenGL
    • 113887-29 patch for OpenGL
    • 119812-08 patch for X11 6.6.2 (dated 2/2010)
    • OpenGL: Sun OpenGL 1.5 patch 120812-31 or any version of Mesa that supports OpenGL 2.0 runtime environment or higher.
    • ArcGIS Engine and ArcGIS Server take advantage of Sun's "extended FILE" facility when running on a Solaris system that supports that functionality. This substantially expands the number of files ArcGIS can have open simultaneously on Solaris. Sun's extended FILE support for SPARC systems is only available on Solaris 10. It is included in Solaris 10 releases done after August 2007.
  • For 64 bit OS support: the 32 bit versions of the packages above must be installed prior to installing ArcGIS.

 

 

Filed under: